recent buzz... Added aerial photo coverage for all of Ward County Texas and Zavala County Texas in the...
Topic Title         Address Search will not work
2017-02-22 07:57:56 I can't get the address search to work anymore. It just shows my current location and won't go to the addresses I type in. Any tips?
2017-02-22 08:05:52 Brett Can't duplicate your problem. If you are entering an address, be sure to include the street number, street name, followed by a "comma" than City followed by a "comma" between the State. You can also enter a zip code or City/State and pan to your location.
2017-02-22 11:09:22 mwanek I too am not able to get the search function to work. I have tried street address, zip code, even the lat/long coordinates and I can't get the viewer to leave the Phoenix, AZ area my viewer opens with.
2017-02-22 12:06:15 Brett What browser are you using? Also, is it the latest version?
2017-02-23 10:42:29 I've tried it on the latest versions of Chrome and IE. I was able to get it to work once but haven't been able to get it to work again since. I put the address in every possible correct way and there is no response when I click search or hit enter.
2017-02-23 22:38:16 our2kids11 I've had the same problem. Internet explorer and Safari.
2017-02-24 00:03:46 Jeff Thank you for the information. I have been trying replicate this issue with no luck. I've tried IE, Chrome, Mozilla and multiple versions of each with results showing every time. I've attempted this as a registered user, subscriber and logged out all giving me a result when I search. Is this a situation where you are getting no results with any search, even a generic search like city, state? Any additional info would be helpful. Did you share your location or not? Are you blocking cookies, running antivirus, adblock, pop-up blockers? I'm concerned this may be specific to certain environments. Many users are having success, so the more information we have to diagnose the issue would be helpful. Feel free to email any information to the contact us email link, if you don't wish to post details on the forum. The only attempt that resulted in nothing happened was when I intentionally misspelled the city name.
2017-02-27 06:49:29 robrieman Same problem here. Internet Explorer 11. Doesn't matter what I type in the search bar, nothing happens when you click search icon or press enter.
2017-02-27 07:43:56 MapSurfer Same issue with the address search not returning any results. Doesn't even appear to be executing the search. I am able to zoom in/out of the map and navigate to the area I'm interested in. I've tried using IE 11 and Google Chrome 56 on a PC running 64bit Windows 7. On my Mac running 64bit MacOS 10.10 with Safari 9 and Chrome 56. Also, the compare function doesn't work properly. Choosing the compare function brings up the second map dates/types on the other side of the screen but the map won't change.
2017-02-27 07:57:51 MapSurfer Also, most browsers are incorporating some form of pop-up blockers as well as a growing number of users are running ad blockers. Requiring users to find and suspend these features is not very user-friendly. It appears that many of the "bells-and-whistles" of the new site are just too sensitive to having users working within the optimum environment and not built to be cross-platform, cross-software compatible. Perhaps the developer could add flexibility for things that the average user has installed and uses on a daily basis.
2017-02-27 09:57:52 Brett It appears to be browser specific which we have been unable to replicate. Is it possible, to turn-off the ad or pop-up blockers to see if this resolves the issue? Most of us don’t like the ads that appear on websites. If it wasn’t for these ads, it’s unlikely the websites you are visiting would exist. It’s the ads and the number of impressions and click thru’s that generate revenue for website owners, publishers, developers, ad networks and the ad exchanges.
2017-02-27 10:41:04 robrieman I have turned off all ad or pop up blockers, deleted all history, cookies, temp files, etc. Still does not work on my IE11. You can type the address but nothing will let you search. Works fine on iPhone if you can stand trying to zoom in and out to use the microscopic controls and re-center the map every time you change something.
2017-02-28 08:44:58 MapSurfer Brett... I understand what you're saying about ads and revenue but most sites that believe they have premium content (like this site) will often move to a subscription model. This only works if you have something no one else does. Several of the old school news sites like the New York Times have moved to subscriptions and they're not finding it very profitable as users just go to another news site that offers equivalent stories for free. Developers can code sites to work with pop-up and ad blockers. Just need to work out the bugs.
2017-02-28 09:20:14 Brett Mapsurfer, we have not even started running ads on the free viewer, yet It was too funny to get complaints for the imaginary ads on the new website. As far as the search function it seems to be a very isolated problem. We have spent countless hours trying to replicate the problem. It seems like it might be a private domain issue. We need to know if people on viewing the website at home or at the office in which the network is blocking certain functions.
2017-02-28 10:13:53 Brett We reviewed the problem again this morning and made a small change. There were two events being monitored, one where the search button is clicked and another when the return button is pressed. There may have been some confusion by some browsers as to which event should get fired. Now, instead of each even calling the geocode routine, they each submit the form which calls the geocode routine. If this does not fix the issue as a temporary solution... if you have the 'map' layer selected, you are able to zoom out beyond the limits we have imposed on our aerial and topo layers. Therefore, if you are unable to search on a location, go to the 'map' layer and zoom out and then zoom in to your location. Until we are sure the search is working, we will leave this 'feature' active.
2017-02-28 12:29:39 V247244 Bring back the old site
2017-02-28 13:20:43 Jeff We were finally able to replicate this issue today. We're looking into it. Someone finally sent an address that was resulting in no response. Informative responses and constructive criticism are much more helpful for us to solve issues.
2017-02-28 17:51:34 Brett Thanks for those sending the error report! We have made a small change and have since been unable to reproduce the error (Version 0.0.39). For those that have this issue, please go back to the viewer ( and refresh your cache by holding the Ctrl and Shift buttons down, then press the R key. After the page refreshes, try to enter an address into the search bar and see if the viewer moves to that location. Then let us know of your result. We appreciate your help and patience!
2017-03-01 08:42:59 MapSurfer Seems to be working now, even the comparison tools are working. Glad you all were able to find the problem on your end and come up with a fix. Appreciate the work.
Please wait while we prepare your image

It appears that you have exhausted your credits for this month. That's ok, we'll spot you a few until your monthly subscription turns over. To get more credits before then, you might want to consider bumping your subscription to the next level. Otherwise, just wait until when you'll receive a new allotment for the month. If you still aren't satisfied, we would be happy to discuss your situation. Just call us during business hours at (xxx) xxx-xxxx.

Unfortunately you have spent your quota of credits for the month. To get more credits before then, you might want to consider bumping your subscription to the next level. Otherwise, just wait until when you'll receive a new allotment for the month. If you still aren't satisfied, we would be happy to discuss your situation. Just call us during business hours at (480) 967-6752.

As a subscriber you are allocated a set number of credits each month. By downloading imagery you will use one or more of your monthly credits.  Topo downloads are included with your subscription and will not be subtracted from your credit allocation.  To continue, simply click Ok, otherwise click Cancel.

 Don't display this again